#1

Alte Erweiterung für eine neue Firefox-Version fit machen

in Mozilla Firefox 14.03.2008 13:38
von vsandre • 604 Beiträge
Mit einer neuen Version des beliebten Browsers Firefox funktionieren bei einem Umstieg auf eine neuere Version oft seine alten und geliebten Erweiterungen nicht mehr. Meist liegt das nur Problem daran, dass die Entwickler der Erweiterung noch keine Zeit gefunden haben, diese in der neuen Version zu testen. Da es aber fast nie zu Problemen kommt, kann man ganz einfach die Installationsdatei der Erweiterung anpassen.

Als erstes lädt man sich die gewünschte Erweiterung aus dem Internet herunter. Dazu mit einem Rechtsklick und dann "Ziel speichern unter". (z.B. deutsches Wörterbuch 1.0.1)

Im nächsten Schritt öffnet man die heruntergeladene Datei mit der Endung XPI mit einem Entpackprogramm, denn das Paket ist nichts anderes als ein ZIP-Archiv. Mit Hilfe eines Texteditors kann man dann in der Datei "install.rdf" die nötigen Veränderungen vornehmen.

Zitat von install.rdf
<?xml version="1.0"?>

<RDF xmlns="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
xmlns:em="http://www.mozilla.org/2004/em-rdf#">
<Description about="urn:mozilla:install-manifest">
<em:id>de-DE@dictionaries.addons.mozilla.org</em:id>
<em:version>1.0.1</em:version>
<em:targetApplication>
<Description>
<em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
<em:minVersion>2.0b1</em:minVersion>
<em:maxVersion>2.0b2</em:maxVersion>
</Description>
</em:targetApplication>
<em:targetApplication>
<Description>
<em:id>{3550f703-e582-4d05-9a08-453d09bdfdc6}</em:id>
<em:minVersion>2.0a1</em:minVersion>
<em:maxVersion>2.0a1</em:maxVersion>
</Description>
</em:targetApplication>
<em:targetApplication>
<Description>
<em:id>{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}</em:id>
<em:minVersion>1.1a</em:minVersion>
<em:maxVersion>1.1</em:maxVersion>
</Description>
</em:targetApplication>
<em:name>Deutsches Wörterbuch</em:name>
</Description>
</RDF>



{ec8030f7-c20a-464f-9b0e-13a3a9e97384} - Bezeichnung für Mozilla Firefox
{3550f703-e582-4d05-9a08-453d09bdfdc6} - Bezeichnung für Mozilla Firefox im Entwicklerzweig

<em:maxVersion>2.0b2</em:maxVersion>
<em:maxVersion>2.0a1</em:maxVersion>
Hier muss jetzt einfach die erlaubte Version in die aktuell verwendete umgetauscht werden, z.B. 3.5
(Aber nur im Bereich maxVersion Veränderungen vornehmen.)

Als nächstes die Datei speichern und wieder dem Archiv hinzufügen. Jetzt kann man die XPI-Datei einfach in das laufenden Firefox-AddOn-Fenster schieben und die Erweiterung wird installiert.

Weitere Informationen zum Aufbau der Installationsdatei findet man zum Beispiel auf dieser Seite.
zuletzt bearbeitet 14.03.2008 13:39 | nach oben springen


OpenStreetMap


Besucher
0 Mitglieder und 3 Gäste sind Online

Wir begrüßen unser neuestes Mitglied: Peter Dehoff
Forum Statistiken
Das Forum hat 621 Themen und 3023 Beiträge.